Can't reset my password

I cleared all my data off my phone and (of course) forgot my password for DiS. Asked to be sent a password reset link to my email, which I put in correctly, and I have not received a link (yes I checked junk). I did this several times over the past few days.

Luckily I’m still logged in on my laptop so I could write this amazing message.

Any advice?

Stupid question first… Are you 100% that the primary email at https://community.drownedinsound.com/u/JoJoMarty/preferences/account is correct?

Have you tried changing that email, then trying the forgot password method? Not sure if it asks you to put your password in again to change email though…

Can you add an “Alternate Email”?
Have you tried “Skip the password; email me a login link” in the login popup?

It’s very strange that you’re not getting the emails though. I just tried the forgot password method with your username, in case there’s some sort of IP blocking going on, so perhaps now you’ll receive one? I just tried a “Forgot Password” on my account and received the email instantly.

I can’t see any issues on the Discourse boards themselves, so nothing to suggest that this is a site-wide problem.

Thanks for replying. I changed my email to another one and still got this message:

We’re sorry, but we’re having trouble reaching you via email. Our last few emails to you have all bounced back as undeliverable.

Can you make sure your email address is valid and working? You may also wish to add our email address to your address book / contact list to improve deliverability.

Is it because I’m still logged in on the laptop?

Are you 100% you’ve got the right email address in there? No typo whatsoever?

If emails are bouncing back as undeliverable, then the problem isn’t at Discourse’s end, it’s getting an error whenever it’s trying to email you, the feature is described here. The reasons this could happen are:

  • You have a typo in your email.
  • Your email provider has blocked the sender for some reason (though you’d think it’d just push it to spam instead of send back an “undeliverable” message).
  • Your inbox is full.
  • You’re using some sort of corporate email where the emails are getting intercepted by some IT support system.
  • Something else that someone who knows shit about email could tell you.

OK, it finally worked when I put in a 3rd email address. The original may have fallen victim to the corporate email thing, not sure why the 2nd didn’t. Anyway thanks a lot for your help.

1 Like